Übersicht
Wenn Sie Screens mit aktiviertem Curtain-Modus verwenden, stellen Sie möglicherweise fest, dass Google Chrome nicht auf Mausklicks reagiert. Andere Anwendungen wie Safari, Finder oder Mail funktionieren weiterhin normal.
Dieses Problem ist nicht spezifisch für Screens und kann auch mit anderen Apps wie Apple Remote Desktop reproduziert werden.
Ursache
Der Curtain-Modus erstellt eine virtuelle Anzeige auf dem Remote-Mac, die dann an die Client-App gestreamt wird.
Im Gegensatz zu nativen macOS-Apps, die auf AppKit basieren, basiert Google Chrome auf plattformübergreifenden Frameworks (Chromium/Skia). Diese Frameworks verarbeiten Rendering und Eingabe unterschiedlich, was dazu führen kann, dass Klicks und andere Interaktionen in Kombination mit dem Curtain-Modus fehlschlagen.
Betroffene Apps
- Google Chrome
- Möglicherweise andere Apps, die nicht auf nativen macOS-Frameworks basieren.
Native macOS-Anwendungen (Safari, Finder, Mail, Systemeinstellungen usw.) sowie die überwiegende Mehrheit der Drittanbieter-Apps sind nicht betroffen.
Problemumgehung
Leider gibt es keine Einstellungen in der Fernverwaltung unter macOS, die dieses Problem beheben könnten.
Die einzige Lösung besteht derzeit darin, den Curtain-Modus bei der Steuerung von Chrome zu vermeiden. Wenn Sie den Curtain-Modus deaktivieren, reagiert Chrome normal auf Mausklicks.
Zusammenfassung
- Dies ist eine bekannte Einschränkung von Chrome im Curtain-Modus.
- Es handelt sich nicht um ein Problem von Screens selbst.
- Die einzige Problemumgehung besteht darin, den Curtain-Modus bei der Steuerung von Chrome zu vermeiden.