O Chrome não responde à interação do mouse quando o modo cortina está ativado

Visão geral

Ao usar Screens com o Modo Cortina ativado, você pode notar que o Google Chrome não responde aos cliques do mouse. Outros aplicativos, como Safari, Finder ou Mail, continuam funcionando normalmente.

Este problema não é específico do Screens e também pode ser reproduzido com outros aplicativos, como o Apple Remote Desktop.

Causa

O Modo Cortina cria uma tela virtual no Mac remoto, que é então transmitida para o aplicativo cliente.

O Google Chrome, diferentemente dos aplicativos nativos do macOS que dependem do AppKit, é desenvolvido em frameworks multiplataforma (Chromium/Skia). Esses frameworks lidam com a renderização e a entrada de dados de forma diferente, o que pode causar falhas em cliques e outras interações quando usado em combinação com o Modo Cortina.

Aplicativos Afetados

Aplicativos nativos do macOS (Safari, Finder, Mail, Preferências do Sistema, etc.), bem como a grande maioria dos aplicativos de terceiros, não são afetados.

Solução alternativa

Infelizmente, não há configurações no Gerenciamento Remoto do macOS que possam ser alteradas para resolver esse problema.

A única solução por enquanto é evitar usar o Modo Cortina quando precisar controlar o Chrome. Se você desativar o Modo Cortina, o Chrome responderá normalmente aos cliques do mouse.

Resumo

Ainda precisa de ajuda?

Envie-nos um e-mail